about Grigoris Maravelias
Replacing repositories for old Ubuntu versions

Replacing repositories for old Ubuntu versions

Ok, I may be outdated regarding my Ubuntu version, but there are two reasons for this (fairly good from my point of view!): (i) I did not like the appearance of Ubuntu 11, and (ii) I have everything set up working in 10.10 than I do not want to change (at least before I finish my PhD).

But that does not come without a cost… I was trying to install IRAF but I was facing a problem like (similar to this error):

The following packages have unmet dependencies:
gfortran : Breaks: gfortran-4.4 (> 4.4.1) ...
E: Broken packages

But when I went on to install gfortran (manually, although the script that was running the IRAF installation should automatically find and install dependencies). Even when I tried the solution provided to the previous link (remove gcc g++ and reinstall them) i was still getting the same error (Broken packages). I played around the software sources (repositories) to see if anything was getting wrong there and I notice that, actually, the did not respond (it couldn’t “Fetch”).

When I looked at the repositories (http://archive.ubuntu.com/ubuntu/dists/) there were nothing for the 10.04, so that’s why it couldn’t locate anything. It was just a matter of a few minutes to find out the solution: older releases that are not supported move to the archive server: http://old-releases.ubuntu.com .

Following the instructions (from the post):
(i) edit the /etc/apt/sources.list and change archive.ubuntu.com to old-releases.ubuntu.com, performed with:

sudo sed -i -e 's/archive.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

(ii) update with

sudo apt-get update && sudo apt-get dist-upgrade

solved the issue with the repositories and the installation of IRAF proceeded smoothly.

Leave a Reply

Your email address will not be published. Required fields are marked *